Geeks With Blogs

News
Archives
Jeff Julian's Blog CEO of Enterprise Marketer

I must say, I love the Internet.  It is snowing outside so I do as I do on all cold morning, go out and start my car when I take the dog out.  This time I forgot to check to see if the windshield wipers were turned on, and they were.  After breakfast I went outside to work my way into the office, but only one windshield wiper worked and it wasn't the driver's side.  So I am lost as this point and I see if I can take back roads to get into the office.  Nope, the windshield still filled up with grime from the road and I turned around to go home and see what I could work on from there. 

My first goal was to see if I could fix it before I started working and low and behold I found this forum.  It seems by these guys understanding of the design that if the wiper gets stuck, the motor will force the bolt that attaches the arm to the motor will loosen on its own, causing the motor to not wear, but just spin. 

To fix the problem, use the following steps:

  1. Remove the plastic cover at the base of the arm.  I has to use pliers to make this happen as it was icy outside
  2. Tighten the bolt underneath the cover with a 12mm socket.  I would strong arm the bolt, because if it is truly design that causes it to loosen, I dont want to mess with that.
  3. Turn on wipers and head off.

Thanks again to the guy on this forum for saving me a trip to AutoZone or my Nissan dealer.

Technorati Tags: ,,
Posted on Wednesday, February 6, 2008 9:09 AM | Back to top


Comments on this post: Internet | Xterra Windshield Wiper Issues

# re: Internet | Xterra Windshield Wiper Issues
Requesting Gravatar...
Wow, am I glad I saw this. I just had the same issue in ice-stricken Pennsylvania. Hard to believe it was that easy...
Left by Steve on Feb 16, 2008 3:32 PM

# re: Internet | Xterra Windshield Wiper Issues
Requesting Gravatar...
The internet is a fantastic and simple way of getting the assistance you need. I had a similar issue with my blades, took the advice, tightened up the bolt and it works like a charm.
Thanks,
KC
Left by kc on Jan 09, 2009 6:12 PM

# re: Internet | Xterra Windshield Wiper Issues
Requesting Gravatar...
Big HooRah for this service. Had this happen to me this morning. After about 10 minutes of searching, here is the answer. About 10 minutes later my wiper is fixed!!! That is sooo cool!!
Left by Pap on Jan 27, 2009 7:59 PM

# re: Internet | Xterra Windshield Wiper Issues
Requesting Gravatar...
Thanks! I just googled Xterra wiper blades and got this site. Perfect and worked like a charm :)
Left by Xterra Owner on Mar 18, 2009 6:52 PM

# re: Internet | Xterra Windshield Wiper Issues
Requesting Gravatar...
Thanks! I had same problem. Easy fix.
Left by kt on Oct 27, 2009 9:40 PM

# re: Internet | Xterra Windshield Wiper Issues
Requesting Gravatar...
Ya saved the day. I was able to fix and avoid trouble as I went for the state inspection today.. Thank YooooU.
Left by Richard on Mar 06, 2010 11:01 AM

# re: Internet | Xterra Windshield Wiper Issues
Requesting Gravatar...
Thank you! I was ready to head over to the repair shop in the morning after a week of my passenger wiper not working. As soon as I read this, I went out to my car at 11pm, flash light in hand, and fixed it myself!
Left by mia on Mar 24, 2011 6:07 PM

# re: Internet | Xterra Windshield Wiper Issues
Requesting Gravatar...
This post offered excellent advice! I simply popped off the wiper arm cover/cap, and tightened the retaining nut. I re-adjusted the wiper alignment and it is perfect.


It is great that we can all help each other and save valuable time and other resources. Thx...
Left by ZUBU on Feb 26, 2015 9:49 AM

Your comment:
 (will show your gravatar)


Copyright © Jeff Julian | Powered by: GeeksWithBlogs.net